Contact Us
Want to advertise here? Contact us today to begin

Clementine Looking Underdeveloped For Day 30 Flower...

Discussion in 'Cannabis Infirmary' started by Chowfarms, Jan 12, 2019.

  1. 0398BAE8-1E0C-4D6B-B5C0-13016B96A8C3.png I apologize in advance if this isn’t the appropriate sub forum for this but my Clementine girls are looking a little underdeveloped for day 30, especially compared to the other strains in this room. I looked all over for other grows running clem and found nothing that helped. They seem to be pretty healthy the flowers are just so small so I’m curious if I messed up somewhere or if this is just how they grow?

    They’re under 600w hps about 16” from bulb to canopy, brand new bulbs. 5gal nursery pots, straight coco. Fed with botanicare pure blend pro + botanicare additives @ 800ppm. PH 5.8-6.0. Room temp is 78-80 degrees, rh between 35-45%. Drip fed till runoff 8x/day now. No CO2..The other strains in this room are doing just fine.

    Thank you in advance
     
  2. 4plant

    4plant

    228
    373
    63
    Could be a slow starter, are you using a p-k boost? 800ppm seems low to start week 4 under a 600w
     
    Chowfarms likes this.
  3. I’m hoping that’s the case! I was feeding them 2-3x/day @ 1000ppm but dialed it back a bit since I started feeding more frequently. I’ve been told too keep it at <1000ppm when doing multiple feeds. Had a very slight amount of burn but they seem to be happy at 800. Just flushed last night, gonna hit em a little harder tonight and see how they respond. I wish I could find a grow diary with some Clem! Lol