Trade acidic soil

  • Thread starter bl2001
  • Start date
  • Tagged users None
B

bl2001

3
3
Hi. I'm not sure what's happening with one of my plants. About a week or so ago, I went to water my plant on schedule and I decided to check the ph and ec of the runoff because I was starting to see some yellowing and brown spots on the first 2 sets of leaves. PH measured at 5.0 and EC was at 2.66. At that point I was only giving the plant bottled water that I was ph'ing to 6.4 and the EC of the bottled water was around 0.13. I decided to flush it with the bottled water but I didn't ph it for the flush. The bottled water ph is 7- 7.1 without using any ph + or -. I managed to bring down the runoff EC to around 0.77 and ph to around 6.1. I left it to dry for a few days and 2 days ago I fed it for the first time. I use advanced nutrients micro,grow and bloom. I got some runoff after the feed and the EC was back to around 2.6 and ph back down to 5.0. I decided to do another flush with same non ph'ed bottled water and brought down the EC to 0.13 but the ph was not budging. It stayed at around 6.0-6.1 and not matter how much water i put in the plant, it would't go up any further. Not sure what is going on and why I even had high EC last week when I was only giving it bottled water with an EC of 0.13. Any advice would be appreciated. Thanks
 
mysticepipedon

mysticepipedon

3,574
263
Welcome.

There must be stuff in the soil that is dissolving or becoming soluble through microbial activity.

A pH of 6.1 is usually OK.
 
B

bl2001

3
3
Welcome.

There must be stuff in the soil that is dissolving or becoming soluble through microbial activity.

A pH of 6.1 is usually OK.
yeah 6.1 is okay. But its a pain having to flush every week.
Welcome.

There must be stuff in the soil that is dissolving or becoming soluble through microbial activity.

A pH of 6.1 is usually OK.
Thanks again. Is there anything I can do to keep my ph more stable and in a good range. Its a pain having to flush it every week only to have the ph go down again after a couple of days
 
mysticepipedon

mysticepipedon

3,574
263
Sprinkle some fine-ground dolomite or other limestone on the surface.
 
R

ritoMox

505
93
Hi. I'm not sure what's happening with one of my plants. About a week or so ago, I went to water my plant on schedule and I decided to check the ph and ec of the runoff because I was starting to see some yellowing and brown spots on the first 2 sets of leaves. PH measured at 5.0 and EC was at 2.66. At that point I was only giving the plant bottled water that I was ph'ing to 6.4 and the EC of the bottled water was around 0.13. I decided to flush it with the bottled water but I didn't ph it for the flush. The bottled water ph is 7- 7.1 without using any ph + or -. I managed to bring down the runoff EC to around 0.77 and ph to around 6.1. I left it to dry for a few days and 2 days ago I fed it for the first time. I use advanced nutrients micro,grow and bloom. I got some runoff after the feed and the EC was back to around 2.6 and ph back down to 5.0. I decided to do another flush with same non ph'ed bottled water and brought down the EC to 0.13 but the ph was not budging. It stayed at around 6.0-6.1 and not matter how much water i put in the plant, it would't go up any further. Not sure what is going on and why I even had high EC last week when I was only giving it bottled water with an EC of 0.13. Any advice would be appreciated. Thanks
This article might shed some light: Link: Soil Amendments and pH
 

Similar threads

Toscano
Replies
1
Views
104
Aqua Man
Aqua Man
M
Replies
3
Views
427
Peat_Phreak
Peat_Phreak
Metrix
Replies
12
Views
375
Metrix
Metrix
Top Bottom