Botanicare Kind Dosage Discrepancies

I'm struggling as I try to get my head around the differences in nutrient dosage amounts between the labels on the bottles & the published feeding chart. I'm using 12-13 gallons of water in a rdwc & separate dwc systems. If I use either suggested dosage amounts I fall woefully short of the target ppm provided on the published chart. For instance... I'm feeding for WK1 Trans/Flower & using the bottle recommendations I am only arriving at 565 ppm while trying to reach a target of 1550! So... I've doubled, then tripled, the dosage amounts for all nutrients (Silica, Base, Grow/Bloom, Vitamino, Fulvex, Tea, CalMag & Hydroplex when in bloom). Even after tripling the bottle dosages I'm still falling short of 1550, by a long shot. Have any of you had the same issue? I'm also using their HydroGuard & some Great White to keep the root systems healthy.. but, I'm still falling short of my goals. I'm following their instructions but I'm not arriving at their target. Should I be supplementing with other ingredients? Any info you could share would be greatly appreciated. I'm a new member. I did search the forums for any related content. If I missed something, I apologize.
 
507
93
When is the last time you calibrated your ec/ppm meter? I would start there. Also what ratio is it using?
 
I'm struggling as I try to get my head around the differences in nutrient dosage amounts between the labels on the bottles & the published feeding chart. I'm using 12-13 gallons of water in a rdwc & separate dwc systems. If I use either suggested dosage amounts I fall woefully short of the target ppm provided on the published chart. For instance... I'm feeding for WK1 Trans/Flower & using the bottle recommendations I am only arriving at 565 ppm while trying to reach a target of 1550! So... I've doubled, then tripled, the dosage amounts for all nutrients (Silica, Base, Grow/Bloom, Vitamino, Fulvex, Tea, CalMag & Hydroplex when in bloom). Even after tripling the bottle dosages I'm still falling short of 1550, by a long shot. Have any of you had the same issue? I'm also using their HydroGuard & some Great White to keep the root systems healthy.. but, I'm still falling short of my goals. I'm following their instructions but I'm not arriving at their target. Should I be supplementing with other ingredients? Any info you could share would be greatly appreciated. I'm a new member. I did search the forums for any related content. If I missed something, I apologize.
I use their pro grow and bloom for soil. I also use cal mag and liquid karma. I follow their feed schedule the ppm are always on with this products based on their instructions so I'd follow aqua's advise and start with ur ppm meter and work from there. Good luck
 
alright! Thanks for the nudge I needed to invest in a better meter. I had been using a cheap tds/combo meter that I was beginning to suspect seriously. I took it to a local shop & the owner tested it for me... it was waay off. I made a solution last night, after tripling, read 920ppm with cheap-o, fairly-new meter. The bluelab pen I just bought reads the same solution at 3340ppm. So, I'm having fun today diluting to appropriate ppm levels.

that pen was the weakest part of my grow.. the weakest link. I think I'm gonna dash it between 2 bricks. Meanwhile..
I really like my new meter. Thanks for quickly reminding me of the fundamentals.
 
507
93
Glad to hear
alright! Thanks for the nudge I needed to invest in a better meter. I had been using a cheap tds/combo meter that I was beginning to suspect seriously. I took it to a local shop & the owner tested it for me... it was waay off. I made a solution last night, after tripling, read 920ppm with cheap-o, fairly-new meter. The bluelab pen I just bought reads the same solution at 3340ppm. So, I'm having fun today diluting to appropriate ppm levels.

that pen was the weakest part of my grow.. the weakest link. I think I'm gonna dash it between 2 bricks. Meanwhile..
I really like my new meter. Thanks for quickly reminding me of the fundamentals.
Glad to hear you got it solved
 
Top