Brown Spots On Fan Leaves

14
3
A few on my plants are starting to have these brown spots on them. Can not tell if it's just a deficiency or something worse like rust rot. They are 7 weeks old so still in veg. I used pro mix hp +, fox farm nutrients. I've had some heating issues the last 7-10 days.
 
Last edited:
  • Like
Reactions: Djr
14
3
It's also not over the whole plant. Mainly it's on the upper leaves, they also are curling down.
 
14
3
Yes, thanks I know that one and am taking care of it. I'm now trying to figure out the issue I have in the post.
 
Last edited:
9,169
313
Which is why I offered that page for a reference, granted it's a pretty quick reference type of thing but, it's pointed me in the right direction in the past, a brief look at it would suggest to me that it might be early potassium deficiency. I saw an issue that I was sure of with the mites and put it out there, just trying to help, thought that's what you were going for here, sorry.
 
14
3
No need to be sorry. Im sorry if you took that the wrong way. I looked at your link and I couldn't figure it out if it is actually one of those. I'm still somewhat inexperienced. Was hoping someone has had this issue before and could tell me.

Again thanks for you help. Greatly appreciated.
 
14
3
Okay. I'll try to add some cal and see if that fixes it. Thanks.

In the picture of cal deficiency it's all over the leaf. Does it matter or mean anything that it's, for now, only on the veins and inseams of the leaf on the plants I have an issue with? If you look at the 3rd pic I have up shows the veins turning purple/brown and on the 4th pic it's only in the creases of the leaf. That might mean nothing at all but noticed that thought it might.
 
Last edited:
14
3
Thanks a lot for the help. I'll try to see if it's a cal issue first if that doesn't work I'll try to see if it's a potassium issue. Would I just use cal mag or something that would just add calcium?
 
14
3
4,270
263
Thanks a lot for the help. I'll try to see if it's a cal issue first if that doesn't work I'll try to see if it's a potassium issue. Would I just use cal mag or something that would just add calcium?
They work well with each other. I used to use CaliMagic it has a higher CA : MG ratio. Now I just use Calcium nitrate and epsom salt to get more CA.
 
293
93
I've never had the problem cause I've always used calmag but as soon as I saw it I thought "either calcium or magnesium." Calmag's my go to. Then again I might not even need it I've just always used it and it has always treated me right. Just recently finished off a gallon I've had for over 5 years. Had bacteria growing in it after a couple years but I grow sterile so it never mattered.

And yeah, spider mites suck. Managed a pretty bad infestation through a couple of flowering cycles in soil using soapy water spray before finally breaking down and buying neem oil spray. By the time I got to use it I was almost done with a cycle and my buds had webs so bad on their tops I had to burn them off with a lighter. Switched to DWC and never had them again.
 
14
3
I've never had the problem cause I've always used calmag but as soon as I saw it I thought "either calcium or magnesium." Calmag's my go to. Then again I might not even need it I've just always used it and it has always treated me right. Just recently finished off a gallon I've had for over 5 years. Had bacteria growing in it after a couple years but I grow sterile so it never mattered.

And yeah, spider mites suck. Managed a pretty bad infestation through a couple of flowering cycles in soil using soapy water spray before finally breaking down and buying neem oil spray. By the time I got to use it I was almost done with a cycle and my buds had webs so bad on their tops I had to burn them off with a lighter. Switched to DWC and never had them again.
Yeah I'm now using calmag. Someone that has been growing for years told me I wouldn't need it when I started the grow but I guess I do lol. It seems to stopped the issue.

I think I got the spider mits from the person I got the clones from to be honest. I'm gonna clean my room and get them from someone else next grow.
 
14
3
It doesn't really seem to be stopping the issue. I'm not really sure what else to do. It seems like I have a nitrogen issue too.
 
14
3
That plant is by far the worst. It's the same issue as before but worse and spreading still. Could it just need more time? Do you guys think I should flush?
 
Last edited:
Top