Having some issues with 1 plant of 4

  • Thread starter GREATWEED24
  • Start date
  • Tagged users None
GREATWEED24

GREATWEED24

39
8
hi there, second time growing here and for some reason only one of my plants is having major issues with those little orange rusty looking spots that turn into what i show in the picture, I use coco with perlite as my medium, and AN perfect PH for my base nuts, i keep wanting to think some sort of def, but if so they would all have the spots as i give them all the exact same thing and exact same mediums. I know that early on i watered her too hard and she fell over, i stood her back up with some support and she started to grow just fine, now shes giving me these issues and i cant help but to think some way some how its playing a role in it. Someone told me could be over watering her but again i feed them all the exact same, but thinking maybe since she had a tumble its effecting her root growth and its smaller therefore needs less water then the rest?? i started to give her much less as of todays feed, but its looking like i might be too late as the perfect upper growth is now beginning to have the tiny rusty dots. PLEASE HELP
cal-mag
cal-mag
cal-mag
cal-mag
cal-mag
cal-mag
 
Oldguy71

Oldguy71

200
63
I’m betting it will grow out of it. I have one with a similar leaf. It’s nothing
 
lvstealth

lvstealth

Supporter
1,320
163
it is only on those two leaves? the new growth is ok?
 
lvstealth

lvstealth

Supporter
1,320
163
i have a plant that at a little younger than yours, i sprayed some water on its leaves, it burned them! they turned more and more brown, from a few dots on the leaves. but nothing else ever turned colors. so just maybe that or something like that happened? the guys here know more, i am just a noob. someone will be along soon and help more.
 
Top Bottom