Help identifying issue with leaves/plant

  • Thread starter dray451
  • Start date
  • Tagged users None
D

dray451

33
18
Having an issue with some leaves. I have a feminized photo alien gorilla glue seed 14 weeks old, 5 weeks/day 34 flower. Promix hp/perlite/ewc using Gaia green dry amendments and recharge. Water phd 6.2-6.8 a little epsom salt every few waterings. Temps between 20 and 26/humidity 40-45. I'm getting concerned with some of the leaves (pics below) and the pace it seems to be happening. I don't believe it is fade and think a magnesium issue? Any advice would be appreciated.
Cheers
 
Help identifying issue with leavesplant
Help identifying issue with leavesplant 2
Help identifying issue with leavesplant 3
GNick55

GNick55

Staff
Supporter
10,696
438
Having an issue with some leaves. I have a feminized photo alien gorilla glue seed 14 weeks old, 5 weeks/day 34 flower. Promix hp/perlite/ewc using Gaia green dry amendments and recharge. Water phd 6.2-6.8 a little epsom salt every few waterings. Temps between 20 and 26/humidity 40-45. I'm getting concerned with some of the leaves (pics below) and the pace it seems to be happening. I don't believe it is fade and think a magnesium issue? Any advice would be appreciated.
Cheers
stop using epsom,.
 
I

imgrowing

157
63
i thought the brown spots meant calcium deficiency, if that's what it is then excess magnesium may be causing lockout.
i think that's what he meant.
maybe
 
GNick55

GNick55

Staff
Supporter
10,696
438
Better safe than sorry. Water is at 7.3. Care to elaborate on " stop using epsom" Trying to learn.
you have what looks to me is a manganese toxicity,.. epsom most plants don’t need that anyways,.
after this grow if you continue everything else the same except for using ewc and epsom, stop ph’ing also,.
i pretty much grow the same way as you,.
 
D

dray451

33
18
you have what looks to me is a manganese toxicity,.. epsom most plants don’t need that anyways,.
after this grow if you continue everything else the same except for using ewc and epsom, stop ph’ing also,.
i pretty much grow the same way as you,.
Thanks for the reply. Ok ph'ing and epsom are gone. You're saying no need for ewc at any point either?
 
GNick55

GNick55

Staff
Supporter
10,696
438
Not really just 444, 284, gypsum and recharge. Any recommendations?
ok, so you could just get by on the gaia stuff,.
if you want to use ewc also than use less gaia when mixing up so you don’t over do it or waste any, lots of calcium in ewc along with nitrogen and everything else so would be good to add some couple week before flowering along with adding the bloom after first week of flowering,.. recharge is good, epsom you could a bit at second/third week flowering,.
than for last 3 weeks only feed a nutrient with numbers similar to this 1-3-5,.. 1-4-5,..
kinda following the plants needs and making the nutrients available during that time,.. like in the chart below,.
IMG 6349

i noticed you posted a picture,. thanks
 
Top Bottom