HLG Blackbird vs. 7EastGenetics Purple Dragons Balls, The Kraken, and Alien BX1

  • Thread starter PerfecTrader
  • Start date
  • Tagged users None
PerfecTrader

PerfecTrader

1,427
263
So funny, I thought I was the only one thinking about getting yucca lol

My plans were to use it in my foliar spray for its surfactant properties

Was looking at Raw brand yucca, is that the same one you guys are looking at? So much cheaper in dry form

Naw I bet tons of people use it. When I pull the trigger I was considering grabbing this
 
ninjadip

ninjadip

1,113
263
Yeah Amazon gets a lot of my $ too lol
I just bought some yucca, but I bought the Raw brand that comes in dry form.

At that application rate it should last me a long time.
 
Screenshot 20221030 141943
PerfecTrader

PerfecTrader

1,427
263
Took the 14grams of sprouted alfalfa and blended with some water then strained. Gave the plants a 1/4gal of Alfalfa SST and also foliar misted the heck out of them with it minutes before lights clicked off. In case they don't make it through the evening due to death by over-Triacontanol-ation or drowning, RIP Purple Dragon Balls, Popa will miss you and is sorry
 
PerfecTrader

PerfecTrader

1,427
263
Day 5 or 6 of Flower. Whelp I think it is time to start payin a bit more attention. Like all half-breed newbie growers I went ahead and moved fast and asked questions later. I am thinkin/hoping this is a magnesium deficiency and or a root zone issue due to not PHin my RO water like ever. Soooo I went ahead and took 1tsp of epsom salt and diluted in 1L of RO @ 6.5 and foliar sprayed my balls from underneath and on top. If I keel them I will just have to sprout new shit is all 🤣 I would rather not have to because they are beginning to grow on me though. Any help appreciated. Lookin for what deficiency this looks like and sorry in advance for lack of info. I know garbage in and garbage out so not expecting much if anything



1667368099312


1667368131069


1667368154005
 
sportyridr

sportyridr

1,145
263
Day 5 or 6 of Flower. Whelp I think it is time to start payin a bit more attention. Like all half-breed newbie growers I went ahead and moved fast and asked questions later. I am thinkin/hoping this is a magnesium deficiency and or a root zone issue due to not PHin my RO water like ever. Soooo I went ahead and took 1tsp of epsom salt and diluted in 1L of RO @ 6.5 and foliar sprayed my balls from underneath and on top. If I keel them I will just have to sprout new shit is all 🤣 I would rather not have to because they are beginning to grow on me though. Any help appreciated. Lookin for what deficiency this looks like and sorry in advance for lack of info. I know garbage in and garbage out so not expecting much if anything



View attachment 1298627

View attachment 1298628

View attachment 1298629

It's Mag def and soon will probably be Cal & phosphorous. The best way to get str8 is to check your input & media pH & ppm/ec. They are a long way from packing it in but throwing new seeds down until you find some that don't care what your growing style is, they just grow, is not the answer friend.

1 tbs epsom in a liter of RO is way too much...it's 1 gram/gal...1 gram = about 1/4 teaspoon
Buy yourself a lil scale to use when needed as well.

Adding more stuff before checking your media is like being a one legged man in a ass kicking contest...get those tools you need to thrive growing my man...thank me later!

Consider flushing if it gets worse...
 
PerfecTrader

PerfecTrader

1,427
263
It's Mag def and soon will probably be Cal & phosphorous. The best way to get str8 is to check your input & media pH & ppm/ec. They are a long way from packing it in but throwing new seeds down until you find some that don't care what your growing style is, they just grow, is not the answer friend.

1 tbs epsom in a liter of RO is way too much...it's 1 gram/gal...1 gram = about 1/4 teaspoon
Buy yourself a lil scale to use when needed as well.

Adding more stuff before checking your media is like being a one legged man in a ass kicking contest...get those tools you need to thrive growing my man...thank me later!

Consider flushing if it gets worse...
damnit and just saw this meow. The 1 teaspoon per liter was because of HERE 😖 but I surely would trust you over that.

Have a couple digital scales

Yeah I was doing exactly that. Adding more shit without having a clue and just assuming. As for checking media. My last feed was just water. The next was to have nutes. Would you advise I 1st run PH'ed to 6.5? RO through the plants and test the runoff of the PH or should I try to do that but with nutes?
 
sportyridr

sportyridr

1,145
263
damnit and just saw this meow. The 1 teaspoon per liter was because of HERE 😖 but I surely would trust you over that.

Have a couple digital scales

Yeah I was doing exactly that. Adding more shit without having a clue and just assuming. As for checking media. My last feed was just water. The next was to have nutes. Would you advise I 1st run PH'ed to 6.5? RO through the plants and test the runoff of the PH or should I try to do that but with nutes?

Just to be sure, has this plant just been up potted recently? This issue can happen while the roots are looking for food, in soil you won't see this happen until a week or so later when it catches up to the plant.

Also to advise you because your in soil, these issues are a bit slower to begin as your seeing the results of maybe a week or so back. Same goes for fixing soil, it will take some time. It's not coco lol.

I would at least run pH'd water thru that plant to some runoff & check pH & EC/ppm to see how you should proceed. If things are out of whack continue to flush (slowly, don't just dump the water thru, do it like your watering) until you get back to correct numbers for your medium. Always finish your flush with light nutes (maybe 1/2 strength), you never want to leave the soil with nothing in it after a flush.

Hope this helps...

Edit: I bet your pH is about 5.4...let us know
 
PerfecTrader

PerfecTrader

1,427
263
Just to be sure, has this plant just been up potted recently? This issue can happen while the roots are looking for food, in soil you won't see this happen until a week or so later when it catches up to the plant.
No these are all reg seeds that were vegged for 6 weeks and are in week 1 of flower
Also to advise you because your in soil, these issues are a bit slower to begin as your seeing the results of maybe a week or so back. Same goes for fixing soil, it will take some time. It's not coco lol.
Yeah I was bad with coco and likely may be worse here with the soil This seems highly if not 100% related to my water source. I am just not sure how to rectify but would think changing my filters should be a start
I would at least run pH'd water thru that plant to some runoff & check pH & EC/ppm to see how you should proceed. If things are out of whack continue to flush (slowly, don't just dump the water thru, do it like your watering) until you get back to correct numbers for your medium. Always finish your flush with light nutes (maybe 1/2 strength), you never want to leave the soil with nothing in it after a flush.
This is all plants. 6 in tent 1 and clone that has grown out in tent 2. I have suspected I was overwatering lately and pots definitely seem they could use another day to dry. I last watered on Sunday but I don't think they needed it. Maybe it would be wise 1 do this with the 3 plants (1, 2, and 3) that are biggest and drink fastest. Their pots are lighter and they would be askin for water sooner. I will do this today
Hope this helps...

Edit: I bet your pH is about 5.4...let us know

Thanks again bud

Calibrated PH60 twice. Also have rep that left me message I will call back just to ensure all my meter settings are set right.

RO Water
PH 6.05
COND 61.4
TDS 43.5
SAL .03

TAP Water
PH 5.8
COND 1010
TDS 716
SAL .5

I would say for the most part, I was feeding about 75-85% RO and the rest TAP. I fill 2 gallon bucket with RO and once at 1.75 gal I would run tap till 2g
 
Last edited:
PerfecTrader

PerfecTrader

1,427
263
Whelp I may not get a single female and that would solve my root issues for now.
Are these balls?
 
PerfecTrader

PerfecTrader

1,427
263
not Fem bracts...I must be passing my crappy luck over to you...

It is all good brotha and I really appreciate your help. If ya don't mind, I'm square up all 6 of the Umbrella Academy and post pics. If they all dudes I'd like to get on with it already and move on. brb
 
PerfecTrader

PerfecTrader

1,427
263
All I need is one but ehh not sure. 1 and 2 look most obviously male. IS 3 a GIRL? Any chance ANY are fems? 4 looks too shitty of pic to tell. To me it looks like a couple need a day or 2 to be able to be sure but I may just be kidding myself.

1
20221102 141212


2

20221102 141312


3
20221102 141540


4
20221102 141659


5
20221102 141745


6

20221102 141838
 

Latest posts

Top Bottom