Irrigation setup with Dab pump and Microdrip system

  • Thread starter EMC2
  • Start date
  • Tagged users None
EMC2

EMC2

59
18
Hi farmers,

I'm trying to finish setting up an irrigation system and one of my lines doesn't seem to be working properly.

My setup is as follows:

60 gal rez connected to a DAB mini pump. From the pump, I have it split off into two lines. Line 1 re-circulates back into the rez (for mixing etc). Line 2 goes into my room and connects to Floraflex micro drip system. Line 1 works great and everything fine there. Line 2 is having issues and I can't figure it out.

Both lines are identical. From the split after the DAB pump, each line has a manual open/close valve followed by a solenoid valve, then a 30PSI regulator and then a check valve. From there Line 1 goes back into the pump, Line 2 goes into my room. The DAB is set to 30PSI which matches my regulators as well as Floraflex' recommendations for the micro drip system.

Currently I am manually opening/closing the valve & solenoid while i'm in testing. Line 2 will start up and water will initially get through the check valve (which is after the open/close valve and the solenoid) and then stutter and water will stop pushing through. The DAB sounds like its still trying to push water through but nothing is getting through the check valve at this point.

Does anyone have any ideas on what I'm doing wrong here? The only thing I could find online was maybe a faulty solenoid but I am manually opening it and water does get through it when i initially turn the pump on.

Thanks farmers
 
Last edited:
XxHammer

XxHammer

527
63
That is a dope ass irrigation setup. I cant wait to own a home and be able to do things on a bigger more professional scale.

Im a newbie BUT I think the issue might be the pump. That is a lot of PVC and I am thinking you might be running into issues with the pump being strong and creating enough pressure to get the water to the end. That is my guess from watching the video. But ive never built an irrigation line so take that into account.

Very clean though. I hope you get your issues resolved.
 
EMC2

EMC2

59
18
That is a dope ass irrigation setup. I cant wait to own a home and be able to do things on a bigger more professional scale.

Im a newbie BUT I think the issue might be the pump. That is a lot of PVC and I am thinking you might be running into issues with the pump being strong and creating enough pressure to get the water to the end. That is my guess from watching the video. But ive never built an irrigation line so take that into account.

Very clean though. I hope you get your issues resolved.
The pump is customizable PSI so I don’t think that’s it.
 
freezeland2

freezeland2

883
143
Hi farmers,

I'm trying to finish setting up an irrigation system and one of my lines doesn't seem to be working properly.

My setup is as follows:

60 gal rez connected to a DAB mini pump. From the pump, I have it split off into two lines. Line 1 re-circulates back into the rez (for mixing etc). Line 2 goes into my room and connects to Floraflex micro drip system. Line 1 works great and everything fine there. Line 2 is having issues and I can't figure it out.

Both lines are identical. From the split after the DAB pump, each line has a manual open/close valve followed by a solenoid valve, then a 30PSI regulator and then a check valve. From there Line 1 goes back into the pump, Line 2 goes into my room. The DAB is set to 30PSI which matches my regulators as well as Floraflex' recommendations for the micro drip system.

Currently I am manually opening/closing the valve & solenoid while i'm in testing. Line 2 will start up and water will initially get through the check valve (which is after the open/close valve and the solenoid) and then stutter and water will stop pushing through. The DAB sounds like its still trying to push water through but nothing is getting through the check valve at this point.

Does anyone have any ideas on what I'm doing wrong here? The only thing I could find online was maybe a faulty solenoid but I am manually opening it and water does get through it when i initially turn the pump on.

Thanks farmers
View attachment 1126031

Is it possible the check valve is in backward?
 
freezeland2

freezeland2

883
143
The pump is customizable PSI so I don’t think that’s it.

There are two other variables beside psi at play here. Velocity and flow. The latter being the issue. I assume the tech support verified your pumps capacity is sufficient for your application?
 
EMC2

EMC2

59
18
Wanted to post an update. Turns out everything was actually working properly from the jump. The micro-drip system is literally that and the water flow is tiny, which led my clear check valve to be barely open (appearing closed to me aka reason for the thread)

Anyway thanks to those that tried to help. Appreciate it
 
Top Bottom