Plant Prod MJ nutrient line

  • Thread starter SixtyPercent
  • Start date
  • Tagged users None
SixtyPercent

SixtyPercent

3
3
Hello, I'm hoping someone can help me with Plant Prod MJ nutrients. I know that a few LPs and some Micros in Canada are having great success with this line. I had been using GH 3 part and a few of their additives for years. Although I feel I was doing very well with GH I have wanted to cut costs and try something new/less gimmicky and just use salts. I grow in 2 gallon pots with coco coir and perlite at a 80/20 ratio. In the room that I am testing Plant Prod MJ in it is sealed with co2 enrichment under gavita double ended lights. R.o. water with a Ph I allow to fluctuate between 6.0-6.3 usually closer to 6.0. My problem is what looks like a calcium and or Magnesium deficiency (to my untrained eyes) and the plants are stunted. I have been mixing the "Cal-Kick" in the water first then adding the "Bloom"/"Grow" after fully mixing. I have done testing with a glass jar to ensure that by mixing I am not causing any of the elements to precipitate out (told to do this by a Plant Prod rep). I'm not sure what I am doing wrong but would really like to save this crop and continue to use this line. I have become more and more dissatisfied with GH as a company and with their products (steadily increased prices with more and more leaky containers) so the switch to salts makes sense to me. Thanks in advance to anyone with some useful knowledge about this line.
 
Dirtbag

Dirtbag

Supporter
7,804
313
What rate are you feeding it at, do you have ppm numbers? I used it for a while but not a whole cycle. It did fine for me and I didn't notice anything odd. But I only used the grow formula on its own with lakewater.
 
SixtyPercent

SixtyPercent

3
3
What rate are you feeding it at, do you have ppm numbers? I used it for a while but not a whole cycle. It did fine for me and I didn't notice anything odd. But I only used the grow formula on its own with lakewater.

What rate are you feeding it at, do you have ppm numbers? I used it for a while but not a whole cycle. It did fine for me and I didn't notice anything odd. But I only used the grow formula on its own with lakewater.
My last couple of feeds were in the 1000ppm range. When I was doing GH 1000 ppm was fine. I'm wondering if I should just be doing the bloom on it's own. Maybe I will try that. Were you in Coco? And thanks for the quick reply
 
Dirtbag

Dirtbag

Supporter
7,804
313
My last couple of feeds were in the 1000ppm range. When I was doing GH 1000 ppm was fine. I'm wondering if I should just be doing the bloom on it's own. Maybe I will try that. Were you in Coco? And thanks for the quick reply
I was in coco actually. Are you supplementing Co2? Those feed numbers are really high to me, i usually keep it 1-1.3ec or about 500-700 ppm or so. Maybe 750 in flower under full lighting, but I grow vented usually.

I would surely not switch to bloom on its own, that won't end well. Just drop ppm down quite a bit and maybe even lower light levels for a few days to let them recover a bit. That's what I'd do anyways.
 
SixtyPercent

SixtyPercent

3
3
Thanks I appreciate it. I did drop my light levels and I may also drop my feed ppm. I usually go upwards of 1400 ppm durring flower though so I'm not sure that's what it is. Thanks again
 

Similar threads

HeLLfiReZ
Replies
13
Views
4K
HeLLfiReZ
HeLLfiReZ
HeavyLungs
Replies
2
Views
875
Dr.Green55
Dr.Green55
Makaz
Replies
8
Views
4K
StealthLED
StealthLED
knf_garden
Replies
6
Views
828
cannaluvme
cannaluvme
Ddebrazza
Replies
2
Views
193
Ddebrazza
Ddebrazza
Top Bottom