What causes ballast to blow? 2 in 2 weeks somethings wrong.

  • Thread starter PipeCarver
  • Start date
  • Tagged users None
PipeCarver

PipeCarver

2,506
263
I've had 2 ballast go on me in the last 2-3 weeks. A Brand new 3 days old and this morning zippo, no light.......FFFFK. Fuse is good power is on everything else is working fine. Wtf. Has anyone had issues with them blowing and found a cause for it? I have an electrical back ground but this is odd. I had an old magnetic ballast that last 10 years. Now 2 so quickly? The last digital ballast only lasted about 16 months, this one 2-3 days. Someone suggested a surge protector but all my other equipment & electronics are fine.. I'll get a good surge protector but WTF is going on?....Gremlins? The short ugly people that live under our front porch? Na....suggestions
 
PipeCarver

PipeCarver

2,506
263
You sure it’s not a bulb or a bulb socket giving you fits?
No I changed the lamp, still no light, its an IPOWER Gblst1000D and it should be new this year When I ordered the ballast they said there was a newer version available for $20 more and do I want the new one...I said sure So I paid for the newest model an H1 - 1000COB-GBL....They're sending me a replacement ballast a shipping label and $20 credit for Amazons delays in shipping and inconvenience. I talked nice to them, They're giving it out to anyone that complains nicely about delayed shipping. I Googled the issues about their current shipping problems and I read about the credit....Fk it takes 3 weeks for 2 day Prime shipping....They're prepared for the complaints with credits in hand.
 
LexLuthor

LexLuthor

2,917
263
Ipower is a relatively low quality ballast, I have seen quite a few complaints about them on Amazon. Hopefully the replacement lasts at least a couple grows to get your money out of it. Goodluck!
 
Shayne010944

Shayne010944

591
93
Have you tried putting your tongue on the probe with it plugged in to see if there’s power?
 
Farmer88

Farmer88

222
43
Have you tried putting your tongue on the probe with it plugged in to see if there’s power?

Or a multimeter.

As far as I can see from internals of the ballast looks like low grade capasitors and sloppy wiring. There has been a shortage of good quality electronic components in the last few years. Can't really know until you can test the internal components, post warranty.
 
PipeCarver

PipeCarver

2,506
263
Have you tried putting your tongue on the probe with it plugged in to see if there’s power?

Or a multimeter.

As far as I can see from internals of the ballast looks like low grade capasitors and sloppy wiring. There has been a shortage of good quality electronic components in the last few years. Can't really know until you can test the internal components, post warranty.
I can get a magnetic ballast cheaper $79 Cdn....1000w Amazon should I cancel and order a magnetic? Why did we switch? the old ones lasted for years.
 
freezeland2

freezeland2

1,080
163
I can get a magnetic ballast cheaper $79 Cdn....1000w Amazon should I cancel and order a magnetic? Why did we switch? the old ones lasted for years.

Don’t know if you can still get them, but my magnetic 1000w is switchable from HPS or MH bulbs.
 
PipeCarver

PipeCarver

2,506
263
Don’t know if you can still get them, but my magnetic 1000w is switchable from HPS or MH bulbs.
Amazon says yes I can get them
1621561615364
 
LexLuthor

LexLuthor

2,917
263
I think Ipower ballasts will strike HPS and MH, they sell kits on Amazon with both bulbs for the same ballast. But if you have an older model maybe they don't work with different bulbs?
 
freezeland2

freezeland2

1,080
163
I think Ipower ballasts will strike HPS and MH, they sell kits on Amazon with both bulbs for the same ballast. But if you have an older model maybe they don't work with different bulbs?

Beside my dual I also have a magnetic that is strictly MH.
 
PipeCarver

PipeCarver

2,506
263
That says for HPS. Will it also spark a MH? Mine will do either. It has a toggle switch to change between the two.
Not sure about the MH, I don't use them. I'm now hoping I haven't tossed my old magnetic ballast housing. I know I have the cover somewhere but I'm not sure about the base. It would be nice to be able to contain this mag ballast kit in my old ballast's housing.
Beside my dual I also have a magnetic that is strictly MH.
No it was a brand new model ( cost me $20 more than the older model) and it would accept both tubes. Amazon has a bunch of revues talking about failures with these ballast but 65% positive revues and it was given a 4+ star rating....shows how the stars on Amazon aren't reflective of their products.
 
chemistry

chemistry

3,737
263
I know it sounds a bit of a dumb question, but are the ballast and the bulb rated at the same wattage? I use my Lumatec digital ballast for MH and HPS, runs both no problem.
 
PipeCarver

PipeCarver

2,506
263
I know it sounds a bit of a dumb question, but are the ballast and the bulb rated at the same wattage? I use my Lumatec digital ballast for MH and HPS, runs both no problem.
Yes...you're right. they are both rated the same...Its all I've ever used, I've no need for MH bulbs and a 2 month old1000w Eye Hortilux is what was in the socket. I replaced lamp with a new shit Vivosun 1000w just to see if the tube had blown. When I get this new kit I'll use the crap bulb to start just to test it then back to the Eye hort.
 
Rooke

Rooke

1,118
263
Heya buddy! I’m just wondering if you ballast has a 15 min cool down feature on it for brown outs? Could that be the problem? Dunno just wondering.....
 

Similar threads

Panhead59
Replies
33
Views
651
Panhead59
Panhead59
GrowDoggy
Replies
3
Views
858
INDICAtive
INDICAtive
Juggernut23
Replies
1
Views
194
Juggernut23
Juggernut23
Top Bottom