Some 420 Fast Buds I grew

  • Thread starter TomZ
  • Start date
  • Tagged users None
T

TomZ

7
3
First one is West Coast Og.
Second one is Wedding Glue.
Third one is Strawberry Banana.
All from Fast Buds. The light is my first Led I bought used. I was told 95% of the bulbs work. As you can see about a third doesn't work. It's a Spider Farmer SF4000. I have two seeds of each Fast Buds seeds for when ever I can get a new light.I have $150 into that light.
 
Some 420 fast buds i grew
Some 420 fast buds i grew 2
Some 420 fast buds i grew 3
Some 420 fast buds i grew 4
Newty

Newty

678
143
Do you see any melting/burnt spot or anything on the diodes or any other failure point anywhere? Any good with a multimeter and soldering iron? Depending on any visual damage, the diodes that are out could be a simple fix such as a bad connection somewhere.
 
T

TomZ

7
3
Do you see any melting/burnt spot or anything on the diodes or any other failure point anywhere? Any good with a multimeter and soldering iron? Depending on any visual damage, the diodes that are out could be a simple fix such as a bad connection somewhere.
I seen green corrosion around the diodes when I got home with it. It's an older one with two meanwell drivers.
 
Newty

Newty

678
143
I seen green corrosion around the diodes when I got home with it. It's an older one with two meanwell drivers.
Get some electrical spary cleaner and clean off the green, it could just be causing a bad connection.

I've seen people vehicles not start because there was green residue on the battery terminals causing a bad connection, simply cleaning it off fixes this issues.

Maybe it will work with the light
 

SpiderFarmerLED

Supporter
1,485
263
Top Bottom