Need help identifying plant issues

  • Thread starter FlyingToast
  • Start date
  • Tagged users None
Aqua Man

Aqua Man

26,480
638
Any idea what's happening here? I see these spots only in old growth in the low parts of the plant, all else seem to be ok
Old dont worry about it for now. Just concentrate on providing a good environment and dialing in nutrients
 
F

FlyingToast

51
18
Old dont worry about it for now. Just concentrate on providing a good environment and dialing in nutrients
i'm certainly on a good direction regarding nutes and environment, and i am working towards really making the most out of your advice, once again thank you for sharing your knowledge, its so valuable! if the problem persists i will return (i removed the affected leaves just in case it is septoria)
 
Aqua Man

Aqua Man

26,480
638
Just saw this problem probably spreading towards top growth here's some pics just in case
What nutrients are you using again and source water?

do you have a fan directly on the plant?

temp and humidity for day and noght?
 
F

FlyingToast

51
18
What nutrients are you using again and source water?

do you have a fan directly on the plant?

temp and humidity for day and noght?
-using GHE flora trio in equal parts (and nothing else as you instructed earlier)
-Source water is Tap water at 0.25 EC (i live in a mediterranean country (south europe) and there are water springs everywhere and water is very healthy even in big cities)

-Yes i do have a fan directly on the plant (pointed at the center of it) And at low speed, my goal is that all the leaves on the plant are barely dancing and ensuring airflow at all parts of the plant (i can upload video in some hours for you to witness the intensity of the air yourself)

Temps are :
Night : 18C (65°F)_
Day : 19.5 - 22C or (67°F-71°F)


RH swings between 50-65% both day and night.no more no less

it also looks like i am in the first day of the "flowering stretch"
 
Top Bottom